Public website loading issues
Incident Report for Thentia Cloud
Resolved
The public website loading issues have been resolved. Thank you for your patience.
Posted Jul 13, 2024 - 21:22 UTC
Investigating
We are actively investigating issues with Thentia's website loading properly. This may affect some Canadian customer websites if hosted by Thentia.
Posted Jul 13, 2024 - 21:00 UTC
This incident affected: Public Website.