After ongoing monitoring, we’ve continued to observe sustained improvements in portal page loading times. Page load times remain steady and have been consistently in line with, or better than, pre-incident rates.
Given the stability observed over an extended period and the absence of new reports, we are confident the underlying issue has been fully addressed. We are declaring this incident resolved.
Posted Jul 07, 2025 - 10:07 EDT
Update
We are continuing to monitor portal page loading times and are seeing sustained improvements. Page load times remain steady and have been consistently in line with, or better than, pre-incident rates.
We will provide another update in the morning of July 7 ET at the latest.
Posted Jul 04, 2025 - 16:06 EDT
Monitoring
We've moving the status of this incident to 'monitoring'.
We've analyzed portal page loading times for several hours since implementing the system changes noted in the previous update to this incident and we've observed great improvements. Portal loading times have been steady at pre-incident rates or better.
We will continue to monitor and will provide another update by 5pm ET at the latest.
Posted Jul 04, 2025 - 12:21 EDT
Update
Yesterday, we released additional system updates aimed at improving portal load times. Based on our testing and monitoring, this update has led to further improvements. We'll be actively monitoring and conducting additional testing throughout the day.
We will provide another update in the afternoon of July 4 ET at the latest.
Posted Jul 04, 2025 - 09:38 EDT
Identified
Beginning on June 26, we received reports that end users were experiencing slow loading times when navigating through pages in the portals (Thentia Cloud - US region).
The root cause has been identified and we've implemented initial improvements which have significantly improved portal page loading times. We continue to test additional remedies to further decrease portal loading times to standard/acceptable levels.
We will provide another update in the morning of July 4 ET at the latest.
Posted Jul 03, 2025 - 17:00 EDT
Monitoring
We have implemented a temporary fix while we work on a more robust fix. We will be monitoring services closely over the next 48 hours.
Posted Jun 26, 2025 - 22:15 EDT
Identified
The issue has been identified and we are working on a fix. Performance has improved to 50% of the speed pre-incident (vs 5% pre-incident).
We will continue to provide updates, but all end users should see a notable increase in performance.
Posted Jun 26, 2025 - 20:03 EDT
Update
We’re continuing to investigate the slowness issues affecting US portals.
Analytics services in the US are recovering and should be functional.
Posted Jun 26, 2025 - 18:35 EDT
Update
We’re continuing to investigate the slowness issues affecting US portals.
Additionally, we’re investigating reports of slow performance in the Workbench Analytics module within US environments. Our team is actively working to identify the root causes and will provide further updates as they become available.
Posted Jun 26, 2025 - 15:05 EDT
Investigating
We’re currently investigating reports of Thentia portals loading slowly. Users may experience delays when logging in or navigating between pages. Our team is actively looking into the issue.
Posted Jun 26, 2025 - 12:47 EDT
This incident affected: Thentia Cloud - USA (Portals - USA).