US Open Regulate systems - possible outage

Incident Report for Thentia Cloud

Resolved

The incident affected Open Regulate systems loading and causing the subsequent login errors has been resolved. Thank you for your patience. Please contact Thentia support if you're still experiencing issues or if you have any questions.
Posted Apr 14, 2026 - 12:50 EDT

Update

We identified remedied a server issue impacting the loading of US Open Regulate systems. The systems are loading. We are now investigating reports of users encountering incorrect login messages.

Next update in 60 minutes (4:30 UTC) or earlier.
Posted Apr 14, 2026 - 12:28 EDT

Investigating

We are investigating reports concerning IUS Open Regulate systems where system and end users are unable to log in and pages are failing to load.

Next update in 60 minutes (4:00PM UTC) or earlier.
Posted Apr 14, 2026 - 11:54 EDT
This incident affected: Legacy Platforms (Open Regulate US).