Thentia and Thentia-hosted websites are currently down
Incident Report for Thentia Cloud
Resolved
The issue affecting Thentia's and some Thentia customers' websites from loading has been resolved.
Posted Nov 13, 2023 - 13:29 UTC
Investigating
We are currently investigating an issue that is preventing Thentia's website from loading. This issue also affects some Thentia customer's websites.
Posted Nov 13, 2023 - 13:19 UTC