Slow Portals - US

Incident Report for Thentia Cloud

Resolved

This incident has been resolved.
Posted Jun 05, 2025 - 00:29 EDT

Monitoring

A fix has been implemented - services are resuming at full speed. We will continue monitoring.
Posted Jun 04, 2025 - 17:40 EDT

Identified

We've identified the issue and we are working on implementing the fix.
Posted Jun 04, 2025 - 16:22 EDT

Update

We are continuing to investigate the degraded performance of portals - we have expanded the scope to include US Open Regulate Portals.

All platforms / workbenches continue to function.
Posted Jun 04, 2025 - 15:18 EDT

Update

We're currently investigating slow portals within Thentia Cloud US.

This is not impacting Workbench interfaces.
Posted Jun 04, 2025 - 15:16 EDT

Investigating

We're currently investigating slow portals within Thentia Cloud US.

This is not impacting Workbench interfaces.
Posted Jun 04, 2025 - 14:48 EDT
This incident affected: Legacy Platforms (Open Regulate US) and Thentia Cloud - Canada (Portals - CA).