Payment issues affecting customers using Authorize.net

Incident Report for Thentia Cloud

Resolved

Authorize. net has declared the issue resolved. We ran a test on our side to confirm payments are working again.
Posted Apr 08, 2026 - 15:41 EDT

Investigating

We are currently monitoring an issue concerning the Authorize.net payment processor. The issue is impacting payments made through Thentia portals where Authorize.net is the connect payment processor.

Invoices may fail to generate after a successful payment attempt, leading to potential duplicate payments and inaccurate application and/or renewal statuses.

Authorize.net is actively working on the issue and posting live updates here: https://status.authorize.net/

Please contact Thentia support https://support.thentia.com with any questions.
Posted Apr 08, 2026 - 11:28 EDT
This incident affected: Legacy Platforms (Open Regulate US) and Thentia Cloud - USA (Portals - USA).