Some of our US portals are having server issues causing indefinite loop and login issues to portals.

Incident Report for Thentia Cloud

Resolved

This incident has been resolved.
Posted May 01, 2026 - 14:56 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 01, 2026 - 14:25 EDT

Investigating

We are currently investigating this issue.
Posted May 01, 2026 - 14:03 EDT
This incident affected: Thentia Cloud - USA (Portals - USA).