Degraded Attachment Performance - US

Incident Report for Thentia Cloud

Resolved

The issues affecting attachment upload and download functionality have been fully resolved.
Posted 1 month ago. Jun 03, 2025 - 10:20 EDT

Monitoring

Issues with uploading and downloading have mostly been resolved as previously indicated.
Posted 1 month ago. Jun 02, 2025 - 19:49 EDT

Identified

Issues related to attachments have been identified and a fix has been implemented for most attachments, including uploading and downloading new attachments. We are continuing our investigation on other attachments that still may be causing an error.
Posted 1 month ago. Jun 02, 2025 - 14:14 EDT

Investigating

We are currently investigating an issue where file attachments are not loading fully or errors are occurring. We are investigating the issue.
Posted 1 month ago. Jun 02, 2025 - 12:44 EDT
This incident affected: Thentia Cloud - USA (Workbench / Platform - USA, Portals - USA).