Issues processing payments through some processors

Incident Report for Thentia Cloud

Resolved

The incident has been resolved for all payments through affected payment processors from this point forward as of 3:50pm UTC.

It has been discovered that during the timeframe of the incident (8:30am UTC on 09/16/25 and 3:50pm UTC 09/17/25), payments were processed successfully through the payment processor, but the response message from the processor failed to post back to Thentia.

For payments processed through Authorize.net during the incident, the processor response will automatically be retried within 48 hours or less and will be successfully posted to Thentia. Therefore, we recommend waiting for this to happen before manually creating payment records or invoices.

We are working with affected customers on an individual basis to assist with necessary remediation efforts.

Thank you for your patience as we worked to resolve this issue.
Posted Sep 17, 2025 - 11:24 EDT

Update

We are continuing to investigate this issue.
Posted Sep 17, 2025 - 10:11 EDT

Update

We are continuing to investigate the issue. The scope has been expanded to include Global Payments. No other payment processors are impacted.
Posted Sep 16, 2025 - 21:37 EDT

Update

We are continuing to investigate this issue.
Posted Sep 16, 2025 - 18:19 EDT

Update

We are continuing to investigate this issue.
Posted Sep 16, 2025 - 18:04 EDT

Investigating

We are investigating reports of issues with transactions processed through Authorize.net.

Transactions are showing as successful in the Authorize.net portal. However, the transactions are remaining in a pending status within Thentia's systems. This appears to be a communication issue between the two applications.

No other payment processors appear to be impacted.

We will post updates as we make progress on our investigation.
Posted Sep 16, 2025 - 17:40 EDT
This incident affected: Thentia Cloud - USA (Workbench / Platform - USA, Portals - USA), Thentia Cloud - Canada (Workbench / Platform - CA, Portals - CA), and Thentia Cloud - European Union (Workbench / Platform - EU, Portals - EU).